{"_id":"5c77b29dbfdb550019e31c20","project":"5773dcfc255e820e00e1cd4d","version":{"_id":"5773dcfc255e820e00e1cd50","__v":26,"project":"5773dcfc255e820e00e1cd4d","createdAt":"2016-06-29T14:36:44.812Z","releaseDate":"2016-06-29T14:36:44.812Z","categories":["5773dcfc255e820e00e1cd51","5773df36904b0c0e00ef05ff","577baf92451b1e0e006075ac","577bb183b7ee4a0e007c4e8d","577ce77a1cf3cb0e0048e5ea","577d11865fd4de0e00cc3dab","578e62792c3c790e00937597","578f4fd98335ca0e006d5c84","578f5e5c3d04570e00976ebb","57bc35f7531e000e0075d118","57f801b3760f3a1700219ebb","5804d55d1642890f00803623","581c8d55c0dc651900aa9350","589dcf8ba8c63b3b00c3704f","594cebadd8a2f7001b0b53b2","59a562f46a5d8c00238e309a","5a2aa096e25025003c582b58","5a2e79566c771d003ca0acd4","5a3a5166142db90026f24007","5a3a52b5bcc254001c4bf152","5a3a574a2be213002675c6d2","5a3a66bb2be213002675cb73","5a3a6e4854faf60030b63159","5c8a68278e883901341de571","5cb9971e57bf020024523c7b","5cbf1683e2a36d01d5012ecd"],"is_deprecated":false,"is_hidden":false,"is_beta":false,"is_stable":true,"codename":"","version_clean":"1.0.0","version":"1.0"},"category":{"_id":"594cebadd8a2f7001b0b53b2","project":"5773dcfc255e820e00e1cd4d","version":"5773dcfc255e820e00e1cd50","__v":0,"sync":{"url":"","isSync":false},"reference":false,"createdAt":"2017-06-23T10:21:33.309Z","from_sync":false,"order":19,"slug":"data-cruncher","title":"Data Cruncher"},"user":"5767bc73bb15f40e00a28777","__v":0,"parentDoc":null,"updates":[],"next":{"pages":[],"description":""},"createdAt":"2019-02-28T10:06:21.416Z","link_external":false,"link_url":"","sync_unique":"","hidden":false,"api":{"results":{"codes":[]},"settings":"","auth":"required","params":[],"url":""},"isReference":false,"order":3,"body":"This page provides a brief description of the RStudio IDE and its commonly used options. \n[block:callout]\n{\n  \"type\": \"info\",\n  \"body\": \"RStudio implementation in Data Cruncher is currently in the beta stage. Please report any issues to [support:::at:::sbgenomics.com](mailto:support@sbgenomics.com).\"\n}\n[/block]\n## The RStudio Interface\nOnce you have set up and started an analysis using RStudio as the editor, the main editor screen is displayed. To start entering your R code, select **File** > **New File** from the main menu, and then select the most suitable file type. Alternatively, you can type your code directly in the **Console** pane.\n\nThis is the default RStudio screen setup with an R file open for editing:\n[block:image]\n{\n  \"images\": [\n    {\n      \"image\": [\n        \"https://files.readme.io/a6acb16-rstudio-quick-reference-1.png\",\n        \"rstudio-quick-reference-1.png\",\n        1440,\n        687,\n        \"#f7f5ef\"\n      ]\n    }\n  ]\n}\n[/block]\n1. **Main menu** - complete set of options available in the RStudio IDE.\n2. **Toolbar** - contains buttons for commonly used commands in RStudio.\n3. **Source** - the main editor window where you can create or open your R scripts/notebooks.\n4. **Environment**, **History**, **Connections**:\n    a. **Environment** - shows all active objects created during your session.\n    b. **History** - keeps a record of all previously entered commands.\n    c. **Connections** - shows you all the connections you have made to supported data sources, and lets you know which connections are currently active. \n5. **Console** - allows you to type R commands directly and see the output.\n6. **Files**, **Plots**, **Packages**, **Help**, **Viewer**:\n    a. **Files** - shows all files and folders in your default workspace.\n    b. **Plots** - shows all your graphs.\n    c. **Packages** - lists a series of packages or add-ons needed to run certain processes.\n    d. **Help** - provides additional learning and reference resources.\n    e. **Viewer** - is similar to the **Plots** tab, but displays HTML output generated by some R functions or Shiny apps.\n7. **Shut down** - Stop the analysis and leave RStudio.\n\nAvailable panes and the appearance of the RStudio environment can be customized using the following options:\n\n  * from the **View** menu on the main menu bar,\n  * using window resizing options in the top-right corner of each window and\n  * by dragging the borders between the panes.","excerpt":"","slug":"rstudio-quick-reference","type":"basic","title":"RStudio quick reference"}

RStudio quick reference


This page provides a brief description of the RStudio IDE and its commonly used options. [block:callout] { "type": "info", "body": "RStudio implementation in Data Cruncher is currently in the beta stage. Please report any issues to [support@sbgenomics.com](mailto:support@sbgenomics.com)." } [/block] ## The RStudio Interface Once you have set up and started an analysis using RStudio as the editor, the main editor screen is displayed. To start entering your R code, select **File** > **New File** from the main menu, and then select the most suitable file type. Alternatively, you can type your code directly in the **Console** pane. This is the default RStudio screen setup with an R file open for editing: [block:image] { "images": [ { "image": [ "https://files.readme.io/a6acb16-rstudio-quick-reference-1.png", "rstudio-quick-reference-1.png", 1440, 687, "#f7f5ef" ] } ] } [/block] 1. **Main menu** - complete set of options available in the RStudio IDE. 2. **Toolbar** - contains buttons for commonly used commands in RStudio. 3. **Source** - the main editor window where you can create or open your R scripts/notebooks. 4. **Environment**, **History**, **Connections**: a. **Environment** - shows all active objects created during your session. b. **History** - keeps a record of all previously entered commands. c. **Connections** - shows you all the connections you have made to supported data sources, and lets you know which connections are currently active. 5. **Console** - allows you to type R commands directly and see the output. 6. **Files**, **Plots**, **Packages**, **Help**, **Viewer**: a. **Files** - shows all files and folders in your default workspace. b. **Plots** - shows all your graphs. c. **Packages** - lists a series of packages or add-ons needed to run certain processes. d. **Help** - provides additional learning and reference resources. e. **Viewer** - is similar to the **Plots** tab, but displays HTML output generated by some R functions or Shiny apps. 7. **Shut down** - Stop the analysis and leave RStudio. Available panes and the appearance of the RStudio environment can be customized using the following options: * from the **View** menu on the main menu bar, * using window resizing options in the top-right corner of each window and * by dragging the borders between the panes.